[Date Prev][Date Next][Thread Prev][Thread Next][Thread Index]

RE: [XaraXtreme-dev] Problem with build...?

I was building in a subdirectory of XaraLX (e.g. a sibling of Kernel)
called debug.  I ran the find command in the XaraLX folder and it only
found two files:


After deleting them the svn up restored wxOil/resources.cpp but the
build still failed with the same error.  The .h file in debug/wxOil was
rebuilt and looks exactly the same as before.

I'll look at it a little bit more when I can spare some time but I'm
going to have to leave it for now...


-----Original Message-----
From: owner-dev@xxxxxxxxxxxxxxxx [mailto:owner-dev@xxxxxxxxxxxxxxxx] On
Behalf Of Alex Bligh
Sent: 06 June 2006 11:54
To: dev@xxxxxxxxxxxxxx
Cc: Alex Bligh
Subject: RE: [XaraXtreme-dev] Problem with build...?

--On 06 June 2006 11:46 +0100 Gerry Iles <GerryI@xxxxxxxx> wrote:

> Well, a fresh copy of the source built without problems so there must
> something wrong with my old source tree.  I guess I'll just make sure
> don't lose anything useful in the old tree and use the fresh copy from
> now on.

It's really annoying as I've seen that cryptic error before. It normally
happens when a .h file gets included twice (or includes itself).
Are you /sure/ you deleted all the copies of resources.h and
(if you are building out-of-tree then check both the TOPDIR and .)