[Date Prev][Date Next][Thread Prev][Thread Next][Thread Index]

Re: [XaraXtreme-dev] Problem with build...?

Gerry Iles wrote:
Well, it's hard to say.  I added both the new options to my configure
and tried to build and it got a fair way but then died with some strange
errors.  Unfortunately, I didn't keep them (though I think it said
something about "assembly") and have started another build without the
new options...

Well I've just checked the code (it's automake that spits it out)
and it is just a warning. All it does is see if you have a macro
there (yes, but may or may not be called), sees if you have po
directory (yes), and if the word "po" is not in a line starting
"SUBDIRS=" and if so, prints a warning. This is supposed to help
people with broken build systems notice it.

Anyway, I have worked around the warning (at least on my system)
so your breakage should now be more silent with the latest
revision :->

I can't think what would cause the build to die from these options.
Difficult to tell without the errors. Are you sure it isn't
whatever broke the build server?