[Date Prev][Date Next][Thread Prev][Thread Next][Thread Index]

RE: [XaraXtreme-dev] Problem with build...?

Well, my build still does it after removing the options.  I changed the
options in KDevelop but it told me to do a make distclean because it was
already configured.

This is the relevant bit:

-DHAVE_DCGETTEXT=1 -I. -I/home/gerry/src/XaraLX/wxOil
-I/usr/local/include/wx-2.6 -D__WXDEBUG__ -D__WXGTK__
-DNO_GCC_PRAGMA -I/usr/include/pango-1.0 -I/usr/X11R6/include
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include
-I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/include/freetype2/config -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I../PreComp
-I../wxOil -I/home/gerry/src/XaraLX/Kernel
-I/home/gerry/src/XaraLX/wxOil -I/home/gerry/src/XaraLX/wxOil/Res
-I/home/gerry/src/XaraLX/tools -I/home/gerry/src/XaraLX/GDraw
-I/home/gerry/src/XaraLX/PreComp -I/home/gerry/src/XaraLX/wxXtra
-Wno-unknown-pragmas -g -fexceptions -ggdb -D_DEBUG
-I/usr/local/include/wx-2.6 -D__WXDEBUG__ -D__WXGTK__
-DNO_GCC_PRAGMA -I/usr/include/pango-1.0 -I/usr/X11R6/include
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/freetype2 -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/u
sr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include
-I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/include/freetype2/config -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -MT resources.o -MD
-MP -MF ".deps/resources.Tpo" -c -o resources.o
/home/gerry/src/XaraLX/wxOil/resources.cpp; then mv -f
".deps/resources.Tpo" ".deps/resources.Po"; else rm -f
".deps/resources.Tpo"; exit 1; fi
/tmp/ccaeR1Ia.s: Assembler messages:
/tmp/ccaeR1Ia.s:449: Error: file number 2 already allocated
gmake[2]: *** [resources.o] Error 1
gmake[1]: *** [all] Error 2
gmake: *** [all-recursive] Error 1
*** Exited with status: 2 ***

With KDevelop set to short output there is a rather suspicious looking
compile of "fi" listed a few files further up between bfxpixop.cpp and
exceptio.cpp.  It looks like there is something "quite iffy" going on...

I'm probably going to have to try getting a completely clean copy from
SVN and building that...


-----Original Message-----
From: owner-dev@xxxxxxxxxxxxxxxx [mailto:owner-dev@xxxxxxxxxxxxxxxx] On
Behalf Of Alex Bligh
Sent: 05 June 2006 18:14
To: dev@xxxxxxxxxxxxxx
Cc: Alex Bligh
Subject: Re: [XaraXtreme-dev] Problem with build...?

Gerry Iles wrote:
> Well, it's hard to say.  I added both the new options to my configure
> and tried to build and it got a fair way but then died with some
> errors.  Unfortunately, I didn't keep them (though I think it said
> something about "assembly") and have started another build without the
> new options...

Well I've just checked the code (it's automake that spits it out)
and it is just a warning. All it does is see if you have a macro
there (yes, but may or may not be called), sees if you have po
directory (yes), and if the word "po" is not in a line starting
"SUBDIRS=" and if so, prints a warning. This is supposed to help
people with broken build systems notice it.

Anyway, I have worked around the warning (at least on my system)
so your breakage should now be more silent with the latest
revision :->

I can't think what would cause the build to die from these options.
Difficult to tell without the errors. Are you sure it isn't
whatever broke the build server?