[Date Prev][Date Next][Thread Prev][Thread Next][Thread Index]

Re: [XaraXtreme-dev] Build problems on Mac

Hi again!

I tried to give the xcode project a shot to get a halfwhat running
xaralx installation at all, but I ran into problems there as well.

I followed the instructions from here [0], downloaded, configured and
build wxWidgets 2.6.4 accordingly (symlinked 2.6.4 to 2.6.3 because of
the hardcoded paths in the xcode project) and then hit the build button
in xcode. After fixing the already mentioned missing header include
(<wx/listctrl.h>) another error popped up:

/Users/tommyd/Entwicklung/XaraLX-0.7r1780/Kernel/jpgsrc.h:132: error:
‘boolean’ in namespace ‘libJPEG’ does not name a type
/Users/tommyd/Entwicklung/XaraLX-0.7r1780/Kernel/jpgsrc.h:134: error:
‘boolean’ in namespace ‘libJPEG’ does not name a type
/Users/tommyd/Entwicklung/XaraLX-0.7r1780/Kernel/imjpeg.cpp:1311: error:
‘class JPEGDataSource’ has no member named ‘InitBuffer’

Just to be sure that this problem wasn't introduced between r1780 and
r1779, I did the same with 1779 again, with the same results.

Any hints?


only dead fish swim with the stream: http://thomaskeller.biz/blog
Am Anfang war das Wort: http://www.schäuble-muss-weg.de

Attachment: signature.asc
Description: OpenPGP digital signature